Differences

This shows you the differences between two versions of the page.

Link to this comparison view

news:2020:10:24:slackwarearm-current-changelog [2020/10/26 09:31] (current)
Giuseppe Di Terlizzi created
Line 1: Line 1:
 +====== Slackwarearm-current ChangeLog (2020-10-24) ======
 +
 +====== Sat Oct 24 08:08:08 UTC 2020 ======
 +>  \\ The mini root filesystem has been updated: \\ ftp://ftp.arm.slackware.com/slackwarearm/slackwarearm-devtools/minirootfs/ \\ 
 +
 +===== Packages =====
 +
 +==== Rebuilt ====
 +  * [[slackwarearm.current>a/aaa_elflibs-15.0-arm-21.txz]] \\   Don't skip this one as it contains the libnsl-2.30.so built by glibc that \\   it's likely many third-party packages will be linking to for some time. \\   Upgraded: libcap.so.2.44, libelf-0.181.so, libpopt.so.0.0.1, \\   libcurl.so.4.7.0, libexpat.so.1.6.12, libglib-2.0.so.0.6600.2, \\   libgmodule-2.0.so.0.6600.2, libgobject-2.0.so.0.6600.2, \\   libgthread-2.0.so.0.6600.2, libidn.so.12.6.1, liblber-2.4.so.2.11.2, \\   libldap-2.4.so.2.11.2, libmpc.so.3.2.0, libmpfr.so.6.1.0, libpsl.so.5.3.3. \\   Added: libnsl-2.30.so, libnsl.so.2.0.1. \\   Removed: libicudata.so.65.1, libicui18n.so.65.1, libicuio.so.65.1, \\   libicutest.so.65.1, libicutu.so.65.1, libicuuc.so.65.1.
 +  * [[slackwarearm.current>a/glibc-solibs-2.30-arm-3.txz]]
 +  * [[slackwarearm.current>a/pam-1.4.0-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>a/quota-4.05-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>a/splitvt-1.6.6-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>a/sysvinit-scripts-2.1-noarch-31.txz]] \\   rc.M: before starting rc.elogind, also check for /bin/loginctl.
 +  * [[slackwarearm.current>ap/linuxdoc-tools-0.9.73-arm-6.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>ap/vorbis-tools-1.4.0-arm-5.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>d/cvs-1.11.23-arm-5.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>d/perl-5.32.0-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>d/python2-2.7.18-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>d/python3-3.8.6-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>d/subversion-1.14.0-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>kde/kdelibs-4.14.38-arm-11.txz]] \\   Use a better patch to support OpenSSL 1.1.x. Thanks to ifo. \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>kde/kopete-4.14.3-arm-9.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>kde/perlkde-4.14.3-arm-11.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>kde/perlqt-4.14.3-arm-12.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>l/glibc-2.30-arm-3.txz]] \\   Rebuilt without the --enable-obsolete-nsl and --enable-obsolete-rpc options. \\   This change has been somewhat overdue, but since glibc was providing these \\   options we just continued to use them here - however, newer versions of \\   glibc have dropped this code entirely and it is expected to be provided in \\   standalone packages. So we'll do that to make things easier moving forward. \\   Please note that libnss_nisplus has been unmaintained upstream for quite \\   some time, is considered obsolete, and no longer compiles. As a result it \\   will no longer be provided... but there are better options these days.
 +  * [[slackwarearm.current>l/glibc-i18n-2.30-arm-3.txz]]
 +  * [[slackwarearm.current>l/glibc-profile-2.30-arm-3.txz]]
 +  * [[slackwarearm.current>l/gmime-3.2.7-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>l/libasyncns-0.8-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>l/loudmouth-1.5.3-arm-6.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>l/mozilla-nss-3.57-arm-2.txz]] \\   This package has not been a security fix since NSS 3.23, so we'll drop it \\   back to the previous version to work around an SSL handshake failure when \\   attempting to connect to talk.google.com with pidgin. Once this issue has \\   been addressed upstream we'll look into bumping the package again. \\   Thanks to Jefferson for the bug report.
 +  * [[slackwarearm.current>n/autofs-5.1.6-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/epic5-2.1.2-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/irssi-1.2.2-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/net-snmp-5.9-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/netatalk-3.1.12-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/ntp-4.2.8p15-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/openldap-2.4.54-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/openssh-8.4p1-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/openvpn-2.4.9-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/postfix-3.5.7-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/ppp-2.4.8-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/procmail-3.22-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/proftpd-1.3.7a-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/rpcbind-1.2.5-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/samba-4.13.0-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/socat-1.7.3.4-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/stunnel-5.57-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/tcp_wrappers-7.6-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/tftp-hpa-5.2-arm-6.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/uucp-1.07-arm-4.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/vsftpd-3.0.3-arm-6.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>xap/gftp-2.0.19-arm-7.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>xap/pidgin-2.14.1-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>xap/rxvt-unicode-9.22-arm-9.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>xap/xine-lib-1.2.10-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>xap/xine-ui-0.99.12-arm-2.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>extra/sendmail/sendmail-8.16.1-arm-3.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>extra/sendmail/sendmail-cf-8.16.1-noarch-3.txz]]
 +
 +==== Upgraded ====
 +  * [[slackwarearm.current>a/btrfs-progs-5.9-arm-1.txz]]
 +  * [[slackwarearm.current>a/glibc-zoneinfo-2020c-noarch-1.txz]] \\   This package provides the latest timezone updates.
 +  * [[slackwarearm.current>a/kernel-firmware-20201023_dae4b4c-noarch-1.txz]]
 +  * [[slackwarearm.current>a/less-563-arm-1.txz]]
 +  * [[slackwarearm.current>a/usbutils-013-arm-1.txz]]
 +  * [[slackwarearm.current>a/xfsprogs-5.9.0-arm-1.txz]]
 +  * [[slackwarearm.current>ap/nvme-cli-1.13-arm-1.txz]]
 +  * [[slackwarearm.current>ap/vim-8.2.1895-arm-1.txz]]
 +  * [[slackwarearm.current>d/ccache-4.0-arm-1.txz]] \\   Please note that the default cache directory has been changed to \\   $HOME/.cache/ccache and the default config file has been changed to \\   $HOME/.config/ccache/ccache.conf. You'll probably want to move your \\   existing config file if you've set any options, and then clear out \\   the old location of $HOME/.ccache to avoid wasting storage space.
 +  * [[slackwarearm.current>d/git-2.29.1-arm-1.txz]]
 +  * [[slackwarearm.current>d/parallel-20201022-noarch-1.txz]]
 +  * [[slackwarearm.current>d/python-pip-20.2.4-arm-1.txz]]
 +  * [[slackwarearm.current>d/python-setuptools-50.3.2-arm-1.txz]]
 +  * [[slackwarearm.current>d/rcs-5.10.0-arm-1.txz]]
 +  * [[slackwarearm.current>l/freetype-2.10.4-arm-1.txz]] \\   Fix heap buffer overflow in embedded PNG bitmap handling. \\   For more information, see: \\     https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-15999 \\   (* Security fix *)
 +  * [[slackwarearm.current>l/glib2-2.66.2-arm-1.txz]]
 +  * [[slackwarearm.current>l/libmpc-1.2.1-arm-1.txz]]
 +  * [[slackwarearm.current>l/libnice-0.1.18-arm-1.txz]]
 +  * [[slackwarearm.current>l/mozjs78-78.4.0esr-arm-1.txz]]
 +  * [[slackwarearm.current>l/python-urllib3-1.25.11-arm-1.txz]]
 +  * [[slackwarearm.current>n/bind-9.16.8-arm-1.txz]] \\   Recompiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>n/nfs-utils-2.5.2-arm-1.txz]]
 +  * [[slackwarearm.current>n/yptools-4.2.3-arm-1.txz]] \\   Compiled against libnsl-1.3.0.
 +  * [[slackwarearm.current>x/fonttosfnt-1.2.0-arm-1.txz]]
 +  * [[slackwarearm.current>x/pyxdg-0.27-arm-1.txz]]
 +  * [[slackwarearm.current>xap/mozilla-firefox-78.4.0esr-arm-1.txz]] \\   This is a bugfix release. \\   For more information, see: \\     https://www.mozilla.org/en-US/firefox/78.4.0/releasenotes/
 +  * [[slackwarearm.current>xap/vim-gvim-8.2.1895-arm-1.txz]]
 +
 +==== Added ====
 +  * [[slackwarearm.current>l/libnsl-1.3.0-arm-1.txz]] \\   This provides the standalone libnsl. \\   Shared library .so-version bump.
 +  * [[slackwarearm.current>l/libnss_nis-3.1-arm-1.txz]]
 +  * [[slackwarearm.current>l/rpcsvc-proto-1.4.2-arm-1.txz]]
 +
 +
 +{{tag>slackware changelog slackwarearm-current 2020/10}}
  
  • news/2020/10/24/slackwarearm-current-changelog.txt
  • Last modified: 4 weeks ago
  • by Giuseppe Di Terlizzi