Slackwarearm-current ChangeLog (2019-01-04)

Fri Jan 04 08:08:08 UTC 2019

  • a/coreutils-8.30-arm-4.txz
    Added xterm-new to DIR_COLORS.
  • a/sysvinit-scripts-2.1-noarch-20.txz
    rc.6: Don't umount /dev/shm or tmpfs mounts under /run as it causes long
    warnings/timeouts at shutdown/reboot on systems using LVM.
    Don't use –ignorelockingfailure when deactivating LVM.
  • a/util-linux-2.33-arm-2.txz
    fdisk: Don't include /dev/ram* devices in 'fdisk -l' output.
  • d/cmake-3.13.2-arm-2.txz
    Work around build failures with recent doxygen.
  • d/subversion-1.11.0-arm-2.txz
    Recompiled against ruby-2.6.0.
  • kde/korundum-4.14.3-arm-6.txz
    Recompiled against ruby-2.6.0.
  • kde/qtruby-4.14.3-arm-7.txz
    Recompiled against ruby-2.6.0.
  • n/epic5-2.0.1-arm-8.txz
    Recompiled against ruby-2.6.0.
  • x/xterm-341-arm-3.txz
    Append new app-defaults for XTerm rather than replacing the upstream file.
    Use 'xterm' rather than 'xterm-new' for termName to avoid surprises, but
    leave the other choice commented out.
    Install XTerm as XTerm.new to avoid wiping out a locally modified file.
    Still not sure we'll be able to stick with this as a default due to Terminus
    possibly not being available on a remote X server. Sure looks nice though.
    Thanks to GazL.
    Install xterm app-defaults that resemble the Linux console. Thanks to GazL.
  • isolinux/*
  • a/ed-1.15-arm-1.txz
  • a/gzip-1.10-arm-1.txz
  • a/kernel-modules-armv7-4.19.13_armv7-arm-1.txz
  • a/kernel_armv7-4.19.13-arm-1.txz
  • a/lvm2-2.03.02-arm-1.txz
  • a/os-prober-1.77-arm-1.txz
  • a/smartmontools-7.0-arm-1.txz
  • a/sysvinit-2.93-arm-1.txz
  • a/tar-1.31-arm-1.txz
  • ap/diffutils-3.7-arm-1.txz
  • ap/mc-4.8.22-arm-1.txz
  • ap/soma-3.2.1-noarch-1.txz
  • d/ccache-3.5.1-arm-1.txz
  • d/doxygen-1.8.15-arm-1.txz
  • d/kernel-headers-4.19.13-arm-1.txz
  • d/ruby-2.6.0-arm-1.txz
    Shared library .so-version bump.
    Recompiled against ruby-2.6.0.
  • k/kernel-source-4.19.13-arm-1.txz
    FRAMEBUFFER_CONSOLE_DEFERRED_TAKEOVER y → n
  • l/gc-8.0.2-arm-1.txz
  • l/gexiv2-0.10.10-arm-1.txz
  • l/gobject-introspection-1.58.3-arm-1.txz
  • l/imagemagick-6.9.10_23-arm-1.txz
  • l/libclc-20181127_1ecb16d-arm-1.txz
  • l/libgphoto2-2.5.22-arm-1.txz
  • l/librsvg-2.44.11-arm-1.txz
  • l/libsecret-0.18.7-arm-1.txz
  • l/libssh-0.8.6-arm-1.txz
  • l/libwpd-0.10.3-arm-1.txz
  • l/zstd-1.3.8-arm-1.txz
  • n/tin-2.4.3-arm-1.txz
  • n/wireless_tools-30.pre9-arm-1.txz
  • n/wpa_supplicant-2.6-arm-1.txz
    It seems we're not the only ones with broken WPA2-Enterprise support
    with wpa_supplicant-2.7, so we'll fix it the same way as everyone else -
    by reverting to wpa_supplicant-2.6 for now.
  • xap/blueman-2.0.7-arm-1.txz
  • xap/gnuplot-5.2.6-arm-1.txz
  • xap/rdesktop-1.8.4-arm-1.txz
  • xap/xscreensaver-5.42-arm-1.txz
  • xfce/xfce4-taskmanager-1.2.2-arm-1.txz
  • kernels/*
  • news/2019/01/04/slackwarearm-current-changelog.txt
  • Last modified: 23 months ago
  • by Giuseppe Di Terlizzi