Slackwarearm-current ChangeLog (2018-12-29)

Sat Dec 29 08:08:08 UTC 2018


The mini root filesystem for -current has been updated:
ftp://ftp.arm.slackware.com/slackwarearm/slackwarearm-devtools/minirootfs/
  • a/aaa_elflibs-15.0-arm-2.txz
    Moved libsigsegv.so.2 from /usr/lib{,64} to /lib{,64}.
    Upgraded: libcap.so.2.26, libelf-0.175.so, libfuse.so.2.9.8,
    libexpat.so.1.6.8, libglib-2.0.so.0.5800.2, libgmodule-2.0.so.0.5800.2,
    libgobject-2.0.so.0.5800.2, libgthread-2.0.so.0.5800.2, libjpeg.so.62.3.0,
    liblber-2.4.so.2.10.10, libldap-2.4.so.2.10.10, libpng16.so.16.36.0,
    libstdc++.so.6.0.25, libtdb.so.1.3.16, libtiff.so.5.4.0,
    libtiffxx.so.5.4.0, libturbojpeg.so.0.2.0.
  • a/coreutils-8.30-arm-3.txz
    Support tmux terms in DIR_COLORS. Thanks to qunying.
  • l/libsigsegv-2.12-arm-3.txz
    Moved shared library into /lib{,64} to avoid problems when /usr is on a
    separate partition. Thanks to TommyC7.
    But please note: that has never been a recommended configuration (it was
    always a bad idea prone to corner-case bugs), and with basically everyone
    else moving everything into /usr, no upstream is developing with this
    scenario in mind these days. Some of the problems caused by separate /usr
    are simply not possibly to fix in a straightforward fashion. Consider it a
    completely unsupported configuration choice.
  • isolinux/*
  • a/e2fsprogs-1.44.5-arm-1.txz
  • a/grep-3.3-arm-1.txz
  • a/kernel-firmware-20181218_0f22c85-noarch-1.txz
  • a/kernel-modules-armv7-4.19.12_armv7-arm-1.txz
  • a/kernel_armv7-4.19.12-arm-1.txz
  • a/sed-4.7-arm-1.txz
  • ap/cups-filters-1.21.6-arm-1.txz
  • ap/groff-1.22.4-arm-1.txz
  • ap/vim-8.1.0648-arm-1.txz
  • d/Cython-0.29.2-arm-1.txz
  • d/bison-3.2.4-arm-1.txz
  • d/gdb-8.2.1-arm-1.txz
  • d/git-2.20.1-arm-1.txz
  • d/kernel-headers-4.19.12-arm-1.txz
  • d/llvm-7.0.1-arm-1.txz
  • d/nasm-2.14.02-arm-1.txz
  • d/parallel-20181222-noarch-1.txz
  • d/rust-1.31.1-arm-1.txz
  • d/strace-4.26-arm-1.txz
  • d/vala-0.42.4-arm-1.txz
  • k/kernel-source-4.19.12-arm-1.txz
  • l/glib2-2.58.2-arm-1.txz
  • l/graphite2-1.3.13-arm-1.txz
  • l/harfbuzz-2.3.0-arm-1.txz
  • l/imagemagick-6.9.10_19-arm-1.txz
  • l/libgsf-1.14.45-arm-1.txz
  • l/lmdb-0.9.23-arm-1.txz
  • l/v4l-utils-1.16.3-arm-1.txz
  • n/gnupg2-2.2.12-arm-1.txz
  • n/netatalk-3.1.12-arm-1.txz
    Netatalk before 3.1.12 is vulnerable to an out of bounds write in
    dsi_opensess.c. This is due to lack of bounds checking on attacker
    controlled data. A remote unauthenticated attacker can leverage
    this vulnerability to achieve arbitrary code execution.
    For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1160
    (* Security fix *)
  • n/openldap-client-2.4.47-arm-1.txz
  • n/samba-4.9.4-arm-1.txz
  • n/wget-1.20.1-arm-1.txz
  • x/libinput-1.12.4-arm-1.txz
  • x/xf86-video-neomagic-1.3.0-arm-1.txz
  • x/xterm-341-arm-1.txz
  • xap/audacious-3.10.1-arm-1.txz
  • xap/audacious-plugins-3.10.1-arm-1.txz
  • xap/mozilla-thunderbird-60.4.0-arm-1.txz
    This is a bugfix release. For more information, see:
    https://www.mozilla.org/en-US/thunderbird/60.4.0/releasenotes/
  • xap/vim-gvim-8.1.0648-arm-1.txz
  • kernels/*
  • news/2018/12/29/slackwarearm-current-changelog.txt
  • Last modified: 21 months ago
  • by Giuseppe Di Terlizzi